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1. Compatibility
1.1 What systems are the printer compatible with?

The thermal label printer is compatible with iOS, Android, and Windows operating systems via
Bluetooth and works with Mac OS via a USB cable connected. It is incompatible with Linux and
Chromebook.

It prints wirelessly via smartphone. By installing and running the app "Shipping Printer" on iPhone,
Android, or iPad to pair Bluetooth. You can import label files to the app to print.

For Windows devices with built-in Bluetooth, you can print wirelessly. But for Mac OS devices, you

can print via USB cable connected only.



1.2 What platforms does OFFNOVA work with?

The thermal label printer can work with any 4" x6" shipping label files from the following platforms.
Amazon/eBay/Shopify/PayPal/Etsy/Poshmark/Endicia/Dazzle/ShipStation/ShipWorks/Shippo/
Shipping Easy/XPS/ORDORO/FedEx/UPS/USPS/DHL / Stamps.com and any other platforms that can

output 4" x 6" shipping label files.

2. Driver Installation
2.1 How to install driver on Windows?

1) Plug the power cord into the electrical outlet and connect the printer with your computer via USB
cable. Switch on the printer.

2) Download the latest driver version from the following link: https://bit.ly/3ipad7G and confirm to

install driver.
3) Please remember the USB Port you connect the printer with. (No label will output whenever the

connecting USB port changes)

I
Select the name and port of printer driver

Select the default installation name and port of printer driver
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3) After installed the driver, please right click on This PC -> Properties -> Control Panel -> Devices and

Printers to find this printer.
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If you can find the printer on the page and can manage it, the driver has been installed successfully;
If it does not display on the page and shows "offline", please recheck the USB connection and reinstall

the driver again.

4) Click on "OFFNOVA Printer" and choose "Printing Preferences". Then confirm the settings to print.
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5) You can watch the following operation video "how to install driver on windows" on the page:

https://offnova.com/pages/tlp-videoguide

2.2 How to install driver on Mac 0S?

1) Plug into the power cord into the electrical outlet and connect the printer with your computer.
Switch on the printer.

2) Download the latest Mac OS driver of OFFNOVA from the following link: https://bit.ly/3uku9yq.
When you open the download file, you should see the screen shown. Please do not worry about it.

You can click "OK" and confirm to install the driver.

“OFFNOVA_Printer-
Mac_OS_Driver_V1.6.8.pkg"
cannot be opened because it is

from an unidentified developer.

macOS cannot verify that this app is free
from malware.

offnova.com

OK
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3) Go to the “System Preferences” and select the “Printer and Scanners” under “Use”. Click “+” to add

OFFNOVA Printer.
@ DingTalk Edit Window He
About This Mac

System Preferences... 1 update
App Store... 18 updates

Recent Items
Force Quit...

Sleep
Restart...
Shut Down...

Lock Screen
Log Out Kelly Wong...

i System Preferences
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manufacturer for the latest software.

Printers & Scanners
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4) If it is not display in “Printers&Scanners”, please check if the printer is on and well connected with

your PC.

5) If yes, but you are unable to install the driver still, please switch off the printer and your PC. Then

restart them to reinstall the driver as steps 1-3.

6) If yes, you can open a file label and confirm settings to printer.



Printer: OFFNOVA N-6140

Presets: Default Settings

Copies: 1 =

Pages: ‘@ All
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7) You can watch the following operation video "how to install driver on Mac OS" on the page:

https://offnova.com/pages/tlp-videoguide

3. How to connect and print via Bluetooth?
3.1 How to print via iPhone and iPad?

OFFNOVA Bluetooth thermal printer is compatible with iPhone and iPad. Please switch on the printer
and ensure that you have installed the app" Shipping Printer" to pair Bluetooth before connecting and

printing. For an iPad, please place it vertically on desk. If not, it will print sideways.

Here are the detailed steps on how to connect Bluetooth to print.

1) Please search and download the app named “Shipping Printer” on your app store.

10:42 4 wi -

€1 Shippingprinter @ Cancel

Shipping Printer
Print PDF/! OPEN
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=
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= =
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2) Switch on the thermal label printer and run the app to pair Bluetooth. If the print icon lights red, it

means the Bluetooth has not been connected.

10:43

Home

3) Choose "connect" in the app, and the print icon will turn green if the Bluetooth is connected

successfully.

Bluetooth

OFFNOVA N-6140_722D-...
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CONNECT
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723CEQF

Choose file

Scan

4) Open a label file and choose to open it via the app" Shipping Printer" and custom size as you

required. (You can input the paper width and height as required directly). Then confirm to print.



ail 4G W

Crop image
Advanced
SAMPLE LABEL Density 3]
6 LB PRICAITY MAK RATE T Range 1-15
20 3 N SURCHARGE
COMMERCIAL PLUS PRIGING
kT ¥ speed
I‘] i || Range 1-8 :
PRIORITY MAIL 2-DAY™
John Smith a9 Copies 1
1234 BARNES RD
CARSON NV 30000
Start x coordinate (mm) 0
sglp DO NOT SHIP
TO: 11 CAMPBELL AVE i
CAMPBELL CA 95009 Start y coordinate (mm) a
Image
USPS TRACKING #
Automatic scale image
888888888838888888853888 e
Default size for unset image
DO NOT SHIP Paper width (mm) 100
Range 38-110mm
Paper height (mm) 150

Mot less than 20mm

Ratio Sotate Left Fistate Right Resat

3.2 How to connect and print Bluetooth via Android?

1) Please search and install the app named “Shipping Printer” on your "Google Play".

43300 9 AM. . e Tl 6%0
& shipping printer Q 9
Shipping Printer
- ]
3.5% 1K+

1 reviews 12 MB Rated for 3+ @ Downloag

i

PDf/IMAGE Print

2) Switch on the printer and run the app "Shipping Printer". Find the device N-6140BT_XXXX or
N-6240BT_XXXX and confirm to connect. The print icon will turn green if the Bluetooth is connected

successfully.
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3) Open the file and choose to open with the app" Shipping Printer".

4) Custom label file size,adjust density and speed, choose copies to print as required. Then confirm to

print.
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3.3 How to connect Bluetooth on Windows?

1) Before installation, please ensure that you have switched on the printer. (Please remove the USB

cable, otherwise it cannot connect via Bluetooth)

2) Follow these steps: Select Start > Settings > Devices> Bluetooth & other devices. Select "Add

Bluetooth or other device"

Settings
@ Home Bluetooth & other devices
| fipdiaissting 2 | Add Bluetooth or other device
+
Devices
Bluetooth
I B Bluetooth & other devices Q on
=W Printers &i=canners Now discoverable as “DESKTOP-5F05SV)
Mouse
0 Mouse, keyboard, & pen
B Touchpad O RAPOO BT3.0 Mouse
Paired
Typing O USB Optical Mouse

cﬁ’ Pen & Windows Ink
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Setti
ettings Add a device

(@ Home Bl Add a device

Choose the kind of device you want to add.

I Find a setting b l

* Bluetooth

Devices Mice, keyboards, pens, or audio and other kinds of Bluetooth devices

Wireless display or dock

Wireless monitors, TVs, or PCs that use Miracast, or wireless docks

Hé‘.: Printers & scanners

Everything else

D Mouse Xbox controllers with Wireless Adapter, DLNA, and more
EJ  Touchpad
Typing

3) Find "OFFNOVA N-6140_XXXX", enter the pairing code "0000".

Settings :
< Add a device

2 Home Bl Add a device

: Make sure your device is turned on and discoverable. Select a device below to
Find a setting 2 e
Devices OFFNOVA N-6140_A17C
Connecting
I EF Bluetooth & other devices Enter the PIN for OFFNOVA N-6140_A17C.

0000 ‘

ﬁ: Printers & scanners
Connect Cancel ‘

D Mouse
S Add a device
@ Home Your device is ready to go!

Find a setting

o

OFFNGVA N-6140_A17C

Devices Paired

4) Choose "More Bluetooth options" > "COM Ports", ensure that the "COMX Port" is enabled for

"OFFNOVA N-6140_XXX" 'SPP Dev'. Remember the com port.

@ Home Bluetooth & other devices

= Turn on Bluetooth even faster
Find a setting £

Add Bluetooth or other device
+

off without
Settings, open action center

To turn Bluetooth on
openi

Geuices and select the Bluetooth icon
Bluetooth
‘ B8 Bluetooth & other devices @ o
Related settings
& Printers & scanners NoWdiscoverableias” DESKTOR-SF03 SV Devices and printers
Sound settings
O Mouse 2
Mouse, keyboard, & pen
Display settings
= RAPOO BT3.0 Mouse
Paired More Bluetooth options
B Typin
yping ['I'] USB Optical Mouse Send or receive files via Bluetooth
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Settings

A RLome Dhivatmntlh O Athav daviicas
£ Bluetooth Settings X
| Find a setting © | Options COM Ports Hardware
This PC is using the COM (serial) ports listed below. To determine
Devices whether you need a COM port, read the documentation that came
with your Bluetooth device.
I B Bluetooth & other devices Ko Birection ) [t

Ccom3 Incoming  QCY-T13

COM4 Outgoing  QCY-T13 'JL SPP*
IEJ Printers & scanners

g OFFNOVA N
COMe Incoming  OFFNOVA N-6140_A17C

O Mouse

5) Install its diver and choose the corresponding USB comport "COM5"
Home S elect Destination Location > ;

Options COM Ports Hardware
U Where should OFFNOVA Printer Driver Setup v1.6.7 be installed?

Yinto Quick Copy Paste
access

This PC is using the COM (serial) ports listed below. To determine
whether you need a COM port, read the documentation that came

ioboard Setup will install OFFNOVA Printer Driver Setup v1.6.7 into the following folder. with your Bluetooth device.
Clipboare
% e alme To continue, click Next. If you would like to select a different folder, click Browse. L Pt Direction | Name
C:\Program Files\OFFNOVA Browse... oM incoming  (OCYTAS
coM4 Outgoing  QCY-T13 'JL_SPP'
Outgoi SPP Dev’
coM6 Incoming ~ OFFNOVA N-6140_A17C
At least 9.5 MB of free disk space is required.
English
Contact us Cancel
Add... Remove
2 W s ( rive 2 ) Bluetooth Settings X
Select the name and port of printer driver Options COM Ports. Hardware
Select the default installation name and port of printer driver
This PC is using the COM (serial) ports listed below. To determine
into Quick Copy. whether you need a COM port, read the documentation that came
access with your Bluetooth device.
Ciip Printer Model:
— Port Direction ~ Name
« v 10 6240 ST com3 Incoming  QCY-T13
P o e . |coma Outgoing  QCY-T13 'JLSPP
CcoM5 Ou OFFNOVA A17C 'SPP Dev'
OFFNOVA Pnn{ COM setting ‘ COM6 Incoming ~ OFFNOVA N-6140_A17C
BaudRate: 115200 ~|  pay:  [NONE |
DataBits: |8 v]  stopsits: [ v
Flow Control: NONE
Printer Disconnected! Setup Exit [shorteut Link

6) Go to the control Panel > Hardware > Devices Printers > OFFNOVA N-6140(1) > Ports > COMS 5

(Always choose the corresponding com ports as step 4. )
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$» Devices and Printers

<« ~ /1 & » Control Panel > Hardware and Sound > Devices and Printers

Add a device Add a printer

~ Devices (4)

N

[N
DESKTOP-5F05S QCY-T13 RAPQOO BT3.0 USB Optical

\ Mouse

V Printers (10)

()

Mouse

== ?

===

Fax HP1FE989 (HP Microsoft Print Microsoft XPS OFFNOVA OFFNOVA OneNote OneNote for
Smart Tank 510 to PDF Document Writer N-6140(1) N-6140_A17C (Desktop) Windows 10
series)
Remove device = .
% OFFNOVA N-6140(1) Properties X

?_ ~

OFFNOVA OFFNOVA
N-6140(1) N-6140_A17C

7) Open a sample label and confirm to print. (Please always ensure that you have calibrated labels,

General Sharing Ports Advanced Color Management Security Device Settings About

% OFFNOVA N-6140(1)

Print to the following port(s). Documents will print to the first free

checked port.

Add Port...

Cornbla kidicamtinma

Port Description
[JLPT1:  Printer Port
[JLPT2:  Printer Port
[ JLPT3:  Printer Port
[JCOM1:  Serial Port
[Jcom2:  Serial Port
[ 1com3: Serial Port
[ ]COM4: _ Serial Port

O rial Port OFFNOVA N-6140(1)

Printer ~

Delete Port Configure Port...

rmmmk

the sizes of label file, label paper, settings on your computer are the same)

4, Print Issues

4.1 Why is the printer printing blank labels?

The three main causes of this problem are as follows:

1) The most common reason is that the labels were loaded upside down. Please ensure your labels
are properly loaded that tearable side should be facing the ceiling when it comes out of OFFNOVA.

2) Label issues: Please ensure your labels are "Direct Thermal" labels and the paper enclosed in the

package meets this condition.

3) The printer has not identify your label's properties. Please follow the steps below to fix the problem.

a. Switch off the printer and restart.

14




b. Open its cover and reload thermal labels, close cover.

c. Press and hold the green feeder button until the printer beeps one time to identify and calibrate your

labels. You should see your label moving back and forth and stopping at the correct tear-off point
d. Try your print and it should print perfectly moving forward until you see a green light.

If the problem cannot be resolved by the above solution, please contact us at

<support@offnova.com>. We are happy to help.

4.2 Why the printer prints sideways?

Generally, only when the sizes of your loaded labels, label files, and settings on your devices are the
same, you can print properly.

If you try to print a 4" x6" USPS label sample, please make sure that the paper size at page setup is
4”x6” and your label size is 4”x6”. In this case, the label sample will prints out fine.

If the label file you use or settings you choose is not 4”x6”, you will print sideways. Please adjust
them to 4"x6" first.

We suggest that you can long-press and hold the green button to identify and calibrate your label
size each time you change labels. Please refer to the following video:
https://s3.amazonaws.com/helpsite-uploads/raa06gjtesdudmOhfdy72p3wfqw%2FnwsoYKmt/8U1617
677368576-Label+calibration.mp4
After that, please check your settings on your computers. If your label is 4 x 6 but just provided

sideways, you can set up OFFNOVA to rotate it for you automatically.

For Mac:
During the print prompt, select your label size under Presets, then navigate to Printer Features

-> Orientation/ Auto -> Click Print

Printer: | OFFNOVA N-6140 B rdance Hein (@
Copies: 5 = Collate Print in grayscale (black and white)
Pages to Print Scale: 100%
Q4 4x6 hches
* Mare Opticns.
Page Sizing & Handling (i)
T804 s ot
Size Poster Muitiple Bookiot ot
Fit Actual size L m“,
© Sheink oversized pages Custom Scale: %
T TRACKRG
Chooss paper source by PDF page size S ol = |I
3403 1178 9900 0
Origntation]
o)
D Auto Portralt Landscape Lt
Comments & Forms eyl
Decument B | summarize Comments b
Page Setup. Printer. | Cancel m
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For Windows:

Go to Control Panel -> Devices and Printers -> Right click on OFFNOVA N-6140-> Go to Settings ->

Under Orientation / Portrait -> Click Apply / Ok.

[ Loyous [ Paper/Qusiy | Page Sevp [Roout |

Stodk

Name llrxs-no:.smmlsumm =
New j | i Delete |

Preview t}i:menul'!on Seming

=) speet:  [Bv)
. i-
- Landscape Densite: |8 T |
ABCD

Fosition Adjustment

it Forrale.1p0 :
Horizontal: a - mm
aseT
Langscape 180 o
Vertseal: o = omm
Media Semings
Method: [DirectTnermal | Twe:  [Label With Gaps ]
Gap/Mark Heighe 3 2 mm Gap/Mark Offset. 0 2 mm
Media Handing
postorine:  [None 7]
Ocowmence After Every Page - Feed Offser 0 = —

If you would like to print other size labels, please watch the following video about "how to set up and

print different size labels":

https://s3.amazonaws.com/helpsite-uploads/raa06gjtesdu9mOhfdy72p3wfqw%2FgeV2cEYx8_A16196

88460388-How+to+set+up+and+print+different+size+labes.mp4

4.3 Why is the red light blinking on the printer?

The red light is an indication that the OFFNOVA Label Printer has not recognized your label and need
to re-learn your label.

By simply press and hold the green feeder button until you hear one short beep. The printer will
move the labels back and forth to learn the gap and other label properties.

If the automatic label identification does not work or the red light remains, please turn off the

printer and restart it again.

4.4 The printer works before but nothing happens when | retry to print?

If the printer lights green but no label advances when you click "Print." The most likely reason is that

you connect the printer into another USB Port.

16
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Device with Windows operating system will register OFFNOVA as a "new" printer whenever the USB
port changes. Thus when you print to the "old" printer, it simply keeps it in the print queue.

You can follow the steps below to fix the problem:
Open your Control Panel -> Printers and Devices and delete the OFFNOVA N-6140. After that, please

re-install a new driver and remember the port you connect to avoid the same problems again.

4.5 The printer does not outputs labels after calibrating?

It is mainly due to that the motor of the printer is defective. The problem is not common and please

contact us back with the S/N number of the printer for a replacement directly.

4.6 It cannot print more than one 4" x6" label per time?

Please download the labels together and ensure that they are in 4" x 6" format in a PDF file, then

open it on your computer or app on your mobile phone to print.

5. Print Quality Issue
5.1 Why the labels are not clear?

1) Please choose PDF file format for printing instead of PNG, PIG, and other image formats, when the
barcode you print out is light and open it with Adobe. (please refer to the picture)

i HANDFLIP 4 (b s ]
100 W.

™

(T

2) If the font is still not clear, please try to increase the density and reduce the speed.

For Mac: Look for drop down menu under "Printer Features".
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Printer: OFFNOVA N-6140

Presets: Default Settings

Copies: 1 3

Pages: ‘® All
From: 1 to:: &

Paper Size: Other 8.50 by 11.00 inches

Orientation: @ +[Z] Portrait +p Landscape

Printer Features Eid

Feature Sets: Printer Settings <

~
<

Media Tracking: | Gap

A

Method: Use Currently Printer Setting
Darkness: | 8 -

~

Print Speed: | 8 inchfsec. b

Cancel

For Windows:

You may access these settings by going to your Control Panel -> Printers and Devices -> Right Click on

OFFNOVA N-6140-> Printer Preferences -> Settings-> Page setup-> Graphical-> Adjust Brightness,

8 OFFNOVA N-6140A Printing Preferences % dgh OFFNOVA N-61404 Printing Preferences x
i T e iy e R b
Stock SAMPLE
New I e J Delete SV
Preview Orientation setting
I
— . Speed: I8 ¥
] =
i € Landscapy
L3 Pasition Adustment
€ Porusit 180 | i
voriontat [0 2] mm
= ight
Landscape 180 —
; o
P E] 3
Low i
Media Settings € Error diffusion s
——— Contrast; ——————— ———————
Method: [DireciThermal ] pe  [lvewimoss  ¥] -
Low High
| = © Pattem
GopiMarkHeight:  |© =] mm Gap/MarkOffiet. [0 = Thimshokd- 5= = | >
Media Handing
postprine:  [None )
Occurrence:  [Aher Every Pags seedomter: 0 =]
o i I

3) Ifitis still not clear for the label, you can wipe the print head with alcohol wipes or wet tissues.

Please clean the print head with alcohol cotton

6. Other issues

6.1 How this printer work with selling platforms or shipping platforms?

The printer does not work with selling platforms or shipping platforms.

please kindly download the labels in 4"x 6" size directly and open them in your computer or

smartphone to print.
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6.2 How to calibrate labels?

1) Switch off the printer and restart.

2) Open its cover and reload thermal labels, close cover.

3) Press and hold the green feeder button until the printer beeps one time to identify and calibrate
your labels. You should see your label moving back and forth and stopping at the correct tear-off
point.

4) Try your print and it should print perfectly moving forward until you see a green light.

Please refer to the following operating video "Thermal Label Printer Preset":

https://offnova.com/pages/tlp-videoguide

6.3 How to print a full size 8.5”x 11” labels?

Some shipping platforms only provide you with a full-page (8.5 x 11") document. For some platforms

like eBay, you can choose to download labels at 4”x6” instead of 8.5” x 11".

1) If your device is a computer, you can follow the steps below to split this page into a 4"x 6" label

size.

. Download Adobe Reader if you do not have it already from the Adobe website.
. Save your label as a PDF file

. Open the file in Adobe Reader

. Rotate the label if needed by going to View -> Rotate View

. Go to Edit -> Take a Snapshot

. Click and drag the box over your label

. Go to File -> Print

° If the preview looks good, click "Print"
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After open the file, please

Go to Edit -> Take a Snapshot of
the grey part

Cliek file to print

2) If your device is iPad or iPhone, you can run the app “FBA Print” to print the 8.5”x11” label file

directly. It will print out the same as 4”x6” label files.

4) If your device is Android, please change the labels from 8.5”x11"” to 4”x6” first.

6.4 How to print Dia 2.25" labels?

Please follow the steps mentioned on 6.2 above to calibrate the label size before printing.
1) Please ensure that the size of your label file is 2.25" x 2.25"

2) Please ensure that the paper size you use is 2.25" x 2.25"

3) Please ensure that the settings on your devices are 2.25" x 2.25".

If your device is a computer, you can follow the steps below: Open the label file -> Print properties ->

Page Setup -> New -> Width and Height -> OK -> Confirm printing.
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8 OFFNOVA N-6140(1) Document Properties

X
Graphical About
Stock
Name: 4" x 6" (101.6mmx152.4mmj) ~ ot v —
Type: |Label =
Preview Orientation Setting |
| 5 8 v
- — (® Partraif Speed: Lsbel Size
Density: & v ;
E ) Landscape i width: [37 ‘mm e ‘
.Jl!ﬂ, Position Adjustment
() portrait 180 —_—
) Horizental: |0 0 mm Expased Liner Width
.o e P
() Landscape 180 . iohi | ‘mm Right: ‘
Vertical: o S mm
Media Settings e
method:  Direct Thermal - Type: Label With Gaps
3 = .
Gap/Mark Height: | 2 mm Gap/MarkOffset: [0 |21 o
Madia Handing
Post-Print: None

#9 OFFNOVA N-6140(1) Document Properties

X
Layout Paper/Quality Page Setup Graphical About
Stock
Name:  |2.25"x2.25" ]
I New l ‘ Edit ‘ ‘ Delete ‘
Preview Orientation Setting

s 8 L4
| — @ Portrait Speed: ;/
- Density: ‘3 4

ABCD O Landscape
[
T2aeser

Position Adjustment

O Portrait 180
Horizontal: 0 mm
O Landscape 180
Vertical: o mm
Media Settings
Method:  Direct Thermal ~ ‘ Type: Label With Gaps
=
Gap/Mark Height: 3 ﬁ—l mm Gap/Mark Offset: 0 % frr
Media Handing
Post-Print: ‘N"“e = ‘ |
Occurrence:  |After Every Page ~ Feed Offset: |0 %I -
Cancel

If your device is a smartphone, please import the file to the app "Shipping Printer" and input the
corresponding size on the app.
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£ Print

Image

Automatic scale image ‘
When image size less then paper size

Size
Default size for unset image

Paper width (mm) |57
Range 38-110mm

Paper height (mm)
Not less than 20mm

57

If it cannot print correctly, please write to us for further support.

6.5 How to reset the printer?

Long press and hold the green feeder button until you hear 4 times short beeps.
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